Wheel Horse Forum

It is currently Sat Aug 30, 2014 6:09 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Jun 22, 2010 7:53 am 
Offline

Joined: Mon Jun 21, 2010 1:49 pm
Posts: 2
I am the proud owner of a 1986/87 Wheel Horse 520h, and my deck needs 3 new blades. The problem that I'm having is removing the old blades. Not one of the bolts, either on the top or the bottom of the blade pully will budge. I've tried a silicone spray and leaving it overnight, but nothing will budge. Is there a trick to removing the old blades that I'm missing?


Top
 Profile  
 
PostPosted: Wed Jun 23, 2010 9:30 am 
Offline

Joined: Sat Jun 19, 2010 3:14 pm
Posts: 3
I use a wooden block. Support it so the other blade doesn't turn. I use a rather large pipe wrench, wack it with a hammer and viola-works for me.


Top
 Profile  
 
PostPosted: Wed Jun 23, 2010 3:51 pm 
Offline

Joined: Wed Dec 15, 2004 6:54 pm
Posts: 480
Hold the nut below the blade, 1-1/8" thin wrench, and use a ratchet and socket on the blade nut. Let the wrench rest against the baffle. PB Blaster works better...

_________________
Mike, in SW Ohio


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group